Withdrawal Processing Issue – Multiple Assets Impacted

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 12:41 UTC

Investigating

Withdrawals delayed across multiple assets due to unexpected error. We are currently investigating this issue.
Posted Feb 04, 2025 - 10:31 UTC
This incident affected: Withdrawals.