MINA Deposits, Withdrawals, and Trading offline for scheduled maintenance at 8:30pm UTC, Mar. 10

Incident Report for CoinList

Resolved

Planned maintenance has ended. MINA deposit, withdrawal, and trading services have been fully restored.
Posted 4 days ago. Mar 12, 2025 - 20:12 UTC

Update

Planned maintenance has started early and will last longer than originally expected. MINA deposits, withdrawals, and trading are temporarily offline and service should be restored in approximately 8 hours.
Posted 6 days ago. Mar 10, 2025 - 19:51 UTC

Identified

Due to planned maintenance, MINA deposits, withdrawals, and trading will be offline for approximately 4 hours starting at 8:30pm UTC, March 10.
Posted 9 days ago. Mar 07, 2025 - 23:12 UTC
This incident affected: Trading, Withdrawals, and Deposits.