FLOW Deposits and Withdrawals Delayed

Incident Report for CoinList

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 08:12 UTC

Identified

Flow mainnet is experiencing degraded performance. Some users may experience delays in FLOW deposits and withdrawals. The Flow team is investigating the issue.
Posted Mar 13, 2025 - 12:15 UTC
This incident affected: Withdrawals and Deposits.