CELO/CUSD Deposits + Withdrawals Disabled - CELO Chain Halted
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 00:18 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2022 - 18:27 UTC
Investigating
The CELO blockchain is currently halted. Deposits and Withdrawals on CoinList have been disabled. CoinList will re-enable deposits and withdrawals once the chain resumes and sufficient stability has been achieved.

No funds are at risk.
Posted Jul 14, 2022 - 03:18 UTC
This incident affected: Withdrawals and Deposits.