BLD Withdrawals Delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 19:24 UTC
Update
We are continuing to investigate this issue.
Posted Nov 16, 2022 - 04:52 UTC
Investigating
We are currently investigating this issue.
Posted Nov 16, 2022 - 04:51 UTC
This incident affected: Withdrawals.