ALGO Deposits are disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 18:18 PDT
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 08:44 PDT
Investigating
We are currently investigating this issue.
Posted Oct 04, 2021 - 08:43 PDT
This incident affected: Deposits.