Coinlist site is experiencing intermittent issues
Incident Report for CoinList
Resolved
The issue has now been resolved.
Posted Feb 04, 2022 - 17:09 UTC
Investigating
We are currently investigating this issue.
Posted Feb 04, 2022 - 13:27 UTC
This incident affected: CoinList - Website.