CELO Deposits and Withdrawals Scheduled for Maintenance

Incident Report for CoinList

Resolved

The CELO network update has finished. Deposits and withdrawals have been enabled for both CELO and cUSD.
Posted Mar 26, 2025 - 21:55 UTC

Update

The CELO network update has begun. Deposits and withdrawals are temporarily disabled for both CELO and cUSD during the scheduled maintenance.
Posted Mar 26, 2025 - 02:59 UTC

Identified

The CELO network will undergo an update on March 26, 2025, at 3:00 AM UTC. CELO and cUSD deposits and withdrawals will be temporarily disabled.
Posted Mar 25, 2025 - 14:43 UTC
This incident affected: Withdrawals and Deposits.