CSPR Withdrawals Delayed
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 20:24 UTC
Investigating
We are experiencing intermittent issues with CSPR withdrawals for users in certain regions.
Posted Nov 02, 2022 - 15:29 UTC
This incident affected: Withdrawals.