CELO + CUSD Deposits Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Nov 26, 2021 - 09:19 PST
Investigating
CELO and CUSD Deposits are disabled while we investigate an issue with our custodian partner
Posted Oct 27, 2021 - 18:13 PDT
This incident affected: Deposits.