MINA Withdrawals Disabled
Incident Report for CoinList
Resolved
This incident has been resolved.
Posted Dec 19, 2024 - 23:26 UTC
Investigating
We are currently investigating the issue.
Posted Dec 18, 2024 - 06:50 UTC
This incident affected: Withdrawals.